Problem
When uninstalling or reinstalling the CrashPlan app on a Windows computer, in rare cases the installer will stop with the error message:
"error getting file security C:\ProgramData\CrashPlan\cache\ GetLastError: 5"
More details about this message from Microsoft Support: Error Code 5 indicates a access denied error.
Environment
- Windows operating system.
- CrashPlan app installed previously on the device.
Resolution
To fix this, manually delete the folder C:\ProgramData\CrashPlan\cache before uninstalling and reinstalling CrashPlan. See the article below for reinstall instructions: Uninstall and reinstall
If you get a permission issue when you try deleting the folder, try granting yourself permission to the folder, and then deleting it.
- The linked YouTube video explains how to give yourself permission to a folder so you can delete it: Folder Access Denied: How to delete any folder in Windows 10
- The detailed steps are provided below.
Change Windows file permissions to delete app's cache
- Open File Explorer.
- Go to the folder C:\ProgramData\CrashPlan\.
- Right-click the Cache folder and choose Properties.
- Click the Security tab of properties.
- Click Advanced to change the owner of the folder.
- Go to where it says "Owner" and click Change.
- Enter your username into the "Enter the object" field.
- Click Check Names.
- Click OK in the Select User or Group window.
- Click the checkbox "Replace owner on subcontainers and objects".
- Click Apply.
- Click Yes to the Windows Security popup.
- Click OK in the Windows Security popup.
- Click OK in the Advanced window.
- Click OK in the properties window.
- Right-click the Cache folder and choose Properties.
- Click the Security tab of properties.
- Click Advanced to save a new principal user name for the folder.
- Click Add.
- Go to where it says "Principal" and click Select a principal.
- Enter your username into the "Enter the object" field.
- Click Check Names.
- Click OK in the select user window.
- In the Basic Permissions, check the "Full Control" checkbox.
- Click OK in the permissions window.
- Click Apply in the Advanced window.
- Check the checkbox "Replace all child object permission entries with inheritable permission entries from this object".
- Click Apply in the Advanced window.
- Click Yes in the Windows Security window.
- Click OK in the Advanced window.
- Click OK in the Properties window.
- Delete the folder C:\ProgramData\CrashPlan\.
Cause
This is caused by a permissions issue in previous versions of the CrashPlan app.