Error getting file security when uninstalling or installing app

Problem

When uninstalling or reinstalling the CrashPlan app on a Windows computer, in rare cases the installer will stop with the error message:

"error getting file security C:\ProgramData\CrashPlan\cache\ GetLastError: 5"

More details about this message from Microsoft Support: Error Code 5 indicates a access denied error. 

Environment 

  • Windows operating system.
  • CrashPlan app installed previously on the device.

Resolution

To fix this, manually delete the folder C:\ProgramData\CrashPlan\cache before uninstalling and reinstalling CrashPlan. See the article below for reinstall instructions: Uninstall and reinstall

If you get a permission issue when you try deleting the folder, try granting yourself permission to the folder, and then deleting it. 

Change Windows file permissions to delete app's cache

  1. Open File Explorer.
  2. Go to the folder C:\ProgramData\CrashPlan\.
  3. Right-click the Cache folder and choose Properties.
  4. Click the Security tab of properties. 
  5. Click Advanced to change the owner of the folder. 
    1. Go to where it says "Owner" and click Change.
    2. Enter your username into the "Enter the object" field.
    3. Click Check Names.
    4. Click OK in the Select User or Group window.
    5. Click the checkbox "Replace owner on subcontainers and objects".
    6. Click Apply.
    7. Click Yes to the Windows Security popup.
    8. Click OK in the Windows Security popup.
    9. Click OK in the Advanced window.
    10. Click OK in the properties window.
  6. Right-click the Cache folder and choose Properties.
  7. Click the Security tab of properties. 
  8. Click Advanced to save a new principal user name for the folder. 
    1. Click Add.
    2. Go to where it says "Principal" and click Select a principal.
    3. Enter your username into the "Enter the object" field.
    4. Click Check Names.
    5. Click OK in the select user window.
    6. In the Basic Permissions, check the "Full Control" checkbox.
    7. Click OK in the permissions window.
    8. Click Apply in the Advanced window.
    9. Check the checkbox "Replace all child object permission entries with inheritable permission entries from this object".
    10. Click Apply in the Advanced window.
    11. Click Yes in the Windows Security window.
    12. Click OK in the Advanced window.
    13. Click OK in the Properties window.
  9. Delete the folder C:\ProgramData\CrashPlan\

Cause 

This is caused by a permissions issue in previous versions of the CrashPlan app.

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