Problem
You are unable to delete a backup set in the CrashPlan app. The option to remove the backup set is unavailable.
Environment
- Multiple backup sets configured in the CrashPlan app
- Backup set settings are not locked at the Organization level
Cause
Each device has a "default" backup set which is the first one that was created when the device was added. The default backup set cannot be deleted.
Resolution
Because you cannot delete the default backup set in favor of a secondary backup set you have created, you must instead merge the secondary backup set's file selection into the default backup set. This allows you to retain the desired data, and then remove the secondary backup set.
Follow the steps below to consolidate your backup sets.
Step 1: Modify the default backup set
Update the default backup set to include the files currently selected in your secondary backup set.
- Open the CrashPlan app.
- Click Manage Files for the default backup set on the Home screen.
- Select the files and locations that are currently in your secondary backup set.
Note: Because the data is already backed up, CrashPlan will use data deduplication to move these files to the new backup set without re-uploading them - (Optional) Deselect any files from the default backup set that you no longer want to back up.
- Click Save.
- Wait for the default backup set to display the message Backup complete.
Step 2: Remove the secondary backup set
Once the default backup set contains all the data you wish to keep, you can safely remove the secondary backup set.
Fully complete Step 1 first
If Step 1 is not fully completed, data in the secondary backup set will be permanently lost once the backup set is removed.
- Click the Backup Set Settings button (gear icon) for the secondary backup set on the Home screen.
- Select Delete Backup Set at the bottom of the settings page.
- Select I understand in the warning dialog.
- Click Remove.