CrashPlan app crashes, restarts unexpectedly, or displays out-of-memory errors

Problem

The CrashPlan app crashes frequently, restarts unexpectedly, or never appears to fully scan or back up your files. You may also observe messages containing “OutOfMemoryError occurred...RESTARTING!” in the app’s service log.

Environment

  • CrashPlan app (all operating systems)
  • Devices with exceptionally large backup selections (typically exceeding 4 TB or 4 million files in size)

Cause

The CrashPlan app requires a certain amount of system memory (RAM) to scan and process your files. As your backup selection grows, the app needs more memory. If the app reaches its maximum allocated memory limit, it may crash or fail to complete scans.

Resolution

To resolve this issue, you must increase the amount of memory available to the CrashPlan app using the app's command-line interface.

Required permissions
These steps assume you have the necessary permissions to edit your CrashPlan app settings. If your organization has locked these settings, you must contact your administrator to perform these steps.

Step 1: Open the command-line interface

Depending on your role and access, open the command line using one of the following methods:

In the CrashPlan app

  1. Open the CrashPlan app and sign in
  2. Double-click the CrashPlan logo in the upper-left corner of the app, or use the keyboard shortcut for your operating system:
    • Windows / Linux: Ctrl+Shift+C
    • macOS: Option+Command+C
  3. The command-line window will open next to the app window.
    For more information on the command-line interface, see CrashPlan Commands reference.

Remotely via the CrashPlan console (Administrators only)

  1. Sign in to the CrashPlan console.
  2. Navigate to Administration > Environment > Devices.
  3. Click on the name of the device to open its details page.
  4. Double-click the operating system icon above the device's name.
    The device's Connection Status must be Online. For more information on the command-line interface, see Command-line interface for CrashPlan app devices.

Step 2: Adjust the memory allocation

Choose one of the two methods below to adjust your memory settings.

Enable dynamic allocation (Recommended)

Newer versions of CrashPlan use dynamic allocation, which automatically allows the app to use up to 25% of the device's physical memory, preventing most crashes in all but the largest backup selections.

  1. In the command-line window, type: java mx clear
  2. Press Enter.
    The command-line window will display the message “none”, confirming the memory setting has been changed to dynamic mode.
  3. In the command-line area, type: restart
  4. Press Enter.
    The CrashPlan app will close and restart with the new memory settings applied.

Set a manual memory limit

If dynamic allocation does not resolve the issue, you can manually assign a specific memory limit based on the size of your backup.

Do not allocate more memory to the CrashPlan app than your device physically has available.

  1. Determine the correct memory value for your backup size. The CrashPlan app requires 1024 MB for each 1 TB or 1 million files in its selection. For example:
    • 2 TB (or 2 million files): 2048
    • 4 TB (or 4 million files): 4096
  2. In the command-line area, type: java mx <value>
    For example, to allocate 2048 MB, type: java mx 2048
  3. Press Enter. The window will display a message confirming the new memory setting.
  4. In the command-line area, type: restart
  5. Press Enter.
    The CrashPlan app will close and restart with the new memory settings applied.

Alternative solution

If your device does not have enough physical RAM to support a higher memory allocation, you can refine your backup selection to reduce the amount of memory required by CrashPlan app using one of the following methods:

  • Reduce your file selection: Deselect system files, application files, non-critical data, or other data you no longer need backed up.
  • Update your global exclusions: Ensure your organization is updated to use the current recommended global exclusions.

Data is permanently removed
Files removed from the backup selection by deselecting or excluding are permanently deleted from the backup archive.

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