Problem
When updating a user's email address on the web console, I received the error "You are not authorized to perform this action" and the email address did not save.
Environment
- Supported web browser
- Signed into the CrashPlan console and have permissions to update Users
- Changing the user's email address fails to save and displays the above error.
Resolution
To fix the "not authorized" error when updating the email address for your Users, change the existing user's email or use a different email address:
- Review the list of Users in the Organization to determine if there is already a user with the email address attempting to be saved.
- If the email address already exists within your organization, Edit the existing User account to use another email address.
When you return to your intended User to update it your preferred email address should be available. - If it's not possible or undesirable to change the existing User's email address, use a unique email address for the account instead.
- Verify the email address was updated successfully.
Cause
CrashPlan requires that all user email addresses in our system be unique. The error "You are not authorized to perform this action" appears because CrashPlan cannot save a duplicate email address.